summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorancarola <raffaele.ancarola@epfl.ch>2019-02-11 12:48:58 +0100
committerancarola <raffaele.ancarola@epfl.ch>2019-02-11 12:48:58 +0100
commit94d90dd045463a540fe14880b1c04e2ce44a1efe (patch)
tree90be7ed7f773d2d627341281373fd22473db21aa /CMakeLists.txt
parentAdd CMake configuration, delete ninja files (diff)
downloadlibmm-94d90dd045463a540fe14880b1c04e2ce44a1efe.tar.gz
libmm-94d90dd045463a540fe14880b1c04e2ce44a1efe.zip
CMakeLists: include fixes, include tree structure modified
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c31e16b..6e7d073 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,8 +63,20 @@ install(TARGETS mm
set_target_properties(mm PROPERTIES EXPORT_NAME MM)
+
+if ("${CMAKE_SYSTEM}" MATCHES "Linux")
+
+# too bad but no other simpler choise
+file(GLOB INCLUDE_FILES "${CMAKE_CURRENT_SOURCE_DIR}/include/*")
+
# install public headers
-install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/include DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+install(FILES ${INCLUDE_FILES}
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/mm
+)
+
+endif()
+
+# TODO, install setup for windows too
# export targets
install(EXPORT mm-targets