summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorNao Pross <naopross@thearcway.org>2019-02-23 13:51:05 +0100
committerNao Pross <naopross@thearcway.org>2019-02-23 13:51:05 +0100
commit27cfe7f190fcfaf3b5c508f0c5dd8ae6ebb2f057 (patch)
treef16fd47fbee92e0bdc2669724c71e94fc9442bee /test/CMakeLists.txt
parentStart specializations of basic_matrix (diff)
parentAdd test to cmake (diff)
downloadlibmm-27cfe7f190fcfaf3b5c508f0c5dd8ae6ebb2f057.tar.gz
libmm-27cfe7f190fcfaf3b5c508f0c5dd8ae6ebb2f057.zip
Merge branch 'master' into matrices
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..e80e737
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,28 @@
+add_executable(vec_example
+ vec_example.cpp
+)
+
+target_compile_options(vec_example
+ PRIVATE
+ $<$<CXX_COMPILER_ID:GNU>:
+ -pedantic -Wall -Wextra -Wcast-qual -Wcast-align -Wpointer-arith
+ -Winit-self -Wshadow -Wswitch-enum -Wredundant-decls -Wfloat-equal
+ -Wundef -Wvla -Wconversion -Wstrict-aliasing
+ >
+ $<$<CXX_COMPILER_ID:MSVC>:/W4>
+)
+
+target_compile_features(vec_example
+ PRIVATE
+ cxx_std_17
+)
+
+target_include_directories(vec_example
+ PRIVATE
+ ${MM_INCLUDE_DIRS}
+)
+
+target_link_libraries(vec_example
+ PRIVATE
+ MM::mm
+)