summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index e80e737..89e7c47 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,3 +1,4 @@
+# vectors example
add_executable(vec_example
vec_example.cpp
)
@@ -26,3 +27,34 @@ target_link_libraries(vec_example
PRIVATE
MM::mm
)
+
+
+# matrix example
+add_executable(matrix_example
+ matrix_example.cpp
+)
+
+target_compile_options(matrix_example
+ PRIVATE
+ $<$<CXX_COMPILER_ID:GNU>:
+ -pedantic -Wall -Wextra -Wcast-qual -Wcast-align -Wpointer-arith
+ -Winit-self -Wshadow -Wswitch-enum -Wredundant-decls -Wfloat-equal
+ -Wundef -Wvla -Wconversion -Wstrict-aliasing
+ >
+ $<$<CXX_COMPILER_ID:MSVC>:/W4>
+)
+
+target_compile_features(matrix_example
+ PRIVATE
+ cxx_std_17
+)
+
+target_include_directories(matrix_example
+ PRIVATE
+ ${MM_INCLUDE_DIRS}
+)
+
+target_link_libraries(matrix_example
+ PRIVATE
+ MM::mm
+)