summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAndrea Censi <AndreaCensi@users.noreply.github.com>2023-05-26 17:41:21 +0200
committerAndrea Censi <AndreaCensi@users.noreply.github.com>2023-05-26 17:41:21 +0200
commitc9c025618571db61d431924934eef6d01a30182a (patch)
tree4c1931472cdad12648a52eb95d0da2e7762bfbff /pyproject.toml
parentinit (diff)
downloadact4e-mcdp-c9c025618571db61d431924934eef6d01a30182a.tar.gz
act4e-mcdp-c9c025618571db61d431924934eef6d01a30182a.zip
misc
Diffstat (limited to '')
-rw-r--r--pyproject.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e70d7c5
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,28 @@
+[project]
+name = "ACT4E-mcdp-MySolution"
+version = "0.1"
+authors = [{ name = "My Name", email = "invalid@invalid.com" }]
+dependencies = [
+ "ACT4E-mcdp",
+]
+
+[tool]
+[tool.poetry]
+name = "ACT4E-mcdp-MySolution"
+version = "0.1"
+description = ""
+authors = ["My Name <invalid@invalid.com>"]
+packages = [
+ { from = "src", include = "act4e_mcdp_solution" },
+]
+[tool.poetry.dependencies]
+python = "^3.10"
+[tool.setuptools]
+packages = [
+ "act4e_mcdp_solution",
+]
+package-dir = { "" = "src" }
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"