aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorNao Pross <np@0hm.ch>2024-03-02 00:47:08 +0100
committerNao Pross <np@0hm.ch>2024-03-02 00:47:08 +0100
commit32a5c57a997794e2cb35d1b74123b4ec15952ef7 (patch)
treefda69cc2cbee6e6e0e10f5c2eb3c959f0ed98775 /pyproject.toml
downloadmdpoly-32a5c57a997794e2cb35d1b74123b4ec15952ef7.tar.gz
mdpoly-32a5c57a997794e2cb35d1b74123b4ec15952ef7.zip
Create empty python project
Diffstat (limited to '')
-rw-r--r--pyproject.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..03e944a
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,15 @@
+[tool.poetry]
+name = "mdpoly"
+version = "0.1.0"
+description = "Multivariate Polynomials"
+authors = ["Nao Pross <np@0hm.ch>"]
+license = "AGPL3"
+readme = "README.md"
+
+[tool.poetry.dependencies]
+python = ">=3.10,<4.0"
+
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"