summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorNao Pross <np@0hm.ch>2024-02-21 10:35:57 +0100
committerNao Pross <np@0hm.ch>2024-04-01 15:35:17 +0200
commitdd088e54893085fd6a6588fa0e5d925284e11734 (patch)
treeefb681030a1324623339260eb939fe3ed1046d67 /pyproject.toml
parentformat Python files with ruff (diff)
downloadpolymatrix-dd088e54893085fd6a6588fa0e5d925284e11734.tar.gz
polymatrix-dd088e54893085fd6a6588fa0e5d925284e11734.zip
Update pyproject.toml to use Poetry for dependency management
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml30
1 files changed, 17 insertions, 13 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3fda5a7..6d78727 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,19 +1,23 @@
-[build-system]
-requires = ["setuptools >= 69.0", "wheel"]
-build-backend = "setuptools.build_meta"
-
-
-[project]
-name = 'polymatrix'
-version = '0.0.1'
+[tool.poetry]
+name = "polymatrix"
+version = "0.0.1"
+description = 'A library to represent and manipulate multivariate polynomials'
authors = [
- { name="Michael Schneeberger", email="michael.schneeberger@fhnw.com" },
+ "Michael Schneeberger <michael.schneeberger@fhnw.ch>",
]
-description = 'A library to represent and manipulate multivariate polynomials'
readme = "README.md"
-requires-python = ">=3.10"
+
+[tool.poetry.dependencies]
+python = ">=3.10"
+sympy = ">=1.12"
+numpy = ">=1.26.4"
+dataclass-abc = ">=0.0.8"
+scipy = "^1.12.0"
-[tool.setuptools.packages]
-find = {}
+[tool.poetry.group.notebook.dependencies]
+marimo = "^0.2.5"
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"