summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Schneeberger <michael.schneeberger@fhnw.ch>2022-08-04 16:18:34 +0200
committerMichael Schneeberger <michael.schneeberger@fhnw.ch>2022-08-04 16:18:34 +0200
commit35f9253a0d19a523e1b10b25a149e3fb8d93c9c8 (patch)
tree7a7bedaf1fd01781ce62be9e2273937477c210d0 /setup.py
parentadd a description of the example given in README.md (diff)
downloadpolymatrix-35f9253a0d19a523e1b10b25a149e3fb8d93c9c8.tar.gz
polymatrix-35f9253a0d19a523e1b10b25a149e3fb8d93c9c8.zip
add 'install_requires' to setup.py, add missing link to README.md
Diffstat (limited to '')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3188bd3..5e09fe8 100644
--- a/setup.py
+++ b/setup.py
@@ -11,7 +11,7 @@ with open(path.join(here, 'README.md'), encoding='utf-8') as f:
setup(
name='polymatrix',
version='0.0.1a1',
- install_requires=['dataclass-abc'],
+ install_requires=['dataclass-abc', 'numpy', 'scipy', 'sympy'],
description='A library to represent and manipulate multivariate polynomials',
long_description=long_description,
long_description_content_type='text/markdown',