diff options
author | Michael Schneeberger <michael.schneeberger@fhnw.ch> | 2022-08-04 15:23:02 +0200 |
---|---|---|
committer | Michael Schneeberger <michael.schneeberger@fhnw.ch> | 2022-08-04 15:23:02 +0200 |
commit | de0f75c08b6d18b52dd5e595d82eecff15e02895 (patch) | |
tree | c06c731f6a9cd8ca7013e8f24c66a8e4c182ea02 /setup.py | |
parent | add max_degree, max and filter operator (diff) | |
download | polymatrix-de0f75c08b6d18b52dd5e595d82eecff15e02895.tar.gz polymatrix-de0f75c08b6d18b52dd5e595d82eecff15e02895.zip |
clean up and restructurings
Diffstat (limited to '')
-rw-r--r-- | setup.py | 27 |
1 files changed, 25 insertions, 2 deletions
@@ -1,5 +1,28 @@ -from setuptools import setup +from setuptools import setup, find_packages +from os import path + + +here = path.abspath(path.dirname(__file__)) + +# Get the long description from the README file +with open(path.join(here, 'README.md'), encoding='utf-8') as f: + long_description = f.read() setup( - name='polymatrix' + name='polymatrix', + version='0.0.1a1', + install_requires=['dataclass-abc'], + description='A library to represent and manipulate multivariate polynomials', + long_description=long_description, + long_description_content_type='text/markdown', + url='https://gitlab.nccr-automation.ch/michael.schneeberger/polysolver', + author='Michael Schneeberger', + author_email='michael.schneeberger@fhnw.com', + classifiers=[ + 'License :: OSI Approved :: MIT License', + 'Programming Language :: Python :: 3.10', + ], + keywords=['multivariate polynomial'], + packages=find_packages(include=['polymatrix', 'polymatrix.*']), + python_requires='>=3.10', )
\ No newline at end of file |