summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Schneeberger <michael.schneeberger@fhnw.ch>2024-02-10 15:28:56 +0100
committerMichael Schneeberger <michael.schneeberger@fhnw.ch>2024-02-10 15:28:56 +0100
commit83a88dfdcf8f2a8ec03022b04a1565c09ac85a5f (patch)
treeba57b77d90f6a6c861f96eb2a5230721ca9c9a11 /setup.py
parentmove init expr functions into a single file (diff)
downloadpolymatrix-83a88dfdcf8f2a8ec03022b04a1565c09ac85a5f.tar.gz
polymatrix-83a88dfdcf8f2a8ec03022b04a1565c09ac85a5f.zip
add pyproject.toml, remove setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 0 insertions, 28 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index 5e09fe8..0000000
--- a/setup.py
+++ /dev/null
@@ -1,28 +0,0 @@
-from setuptools import setup, find_packages
-from os import path
-
-
-here = path.abspath(path.dirname(__file__))
-
-# Get the long description from the README file
-with open(path.join(here, 'README.md'), encoding='utf-8') as f:
- long_description = f.read()
-
-setup(
- name='polymatrix',
- version='0.0.1a1',
- install_requires=['dataclass-abc', 'numpy', 'scipy', 'sympy'],
- description='A library to represent and manipulate multivariate polynomials',
- long_description=long_description,
- long_description_content_type='text/markdown',
- url='https://gitlab.nccr-automation.ch/michael.schneeberger/polysolver',
- author='Michael Schneeberger',
- author_email='michael.schneeberger@fhnw.com',
- classifiers=[
- 'License :: OSI Approved :: MIT License',
- 'Programming Language :: Python :: 3.10',
- ],
- keywords=['multivariate polynomial'],
- packages=find_packages(include=['polymatrix', 'polymatrix.*']),
- python_requires='>=3.10',
-) \ No newline at end of file