summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..3fda5a7
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,19 @@
+[build-system]
+requires = ["setuptools >= 69.0", "wheel"]
+build-backend = "setuptools.build_meta"
+
+
+[project]
+name = 'polymatrix'
+version = '0.0.1'
+authors = [
+ { name="Michael Schneeberger", email="michael.schneeberger@fhnw.com" },
+]
+description = 'A library to represent and manipulate multivariate polynomials'
+readme = "README.md"
+requires-python = ">=3.10"
+
+
+[tool.setuptools.packages]
+find = {}
+