diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 27 |
1 files changed, 25 insertions, 2 deletions
@@ -1,5 +1,28 @@ -from setuptools import setup +from setuptools import setup, find_packages +from os import path + + +here = path.abspath(path.dirname(__file__)) + +# Get the long description from the README file +with open(path.join(here, 'README.md'), encoding='utf-8') as f: + long_description = f.read() setup( - name='polymatrix' + name='polymatrix', + version='0.0.1a1', + install_requires=['dataclass-abc'], + description='A library to represent and manipulate multivariate polynomials', + long_description=long_description, + long_description_content_type='text/markdown', + url='https://gitlab.nccr-automation.ch/michael.schneeberger/polysolver', + author='Michael Schneeberger', + author_email='michael.schneeberger@fhnw.com', + classifiers=[ + 'License :: OSI Approved :: MIT License', + 'Programming Language :: Python :: 3.10', + ], + keywords=['multivariate polynomial'], + packages=find_packages(include=['polymatrix', 'polymatrix.*']), + python_requires='>=3.10', )
\ No newline at end of file |