summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorNao Pross <np@0hm.ch>2024-02-22 15:56:17 +0100
committerNao Pross <np@0hm.ch>2024-03-25 18:33:37 +0100
commit10b2e89c6d02dd396c951d652af437687e4db331 (patch)
tree45bfd329afd6fece7c8ca822573bb91c5ffefc15 /pyproject.toml
parentMerge branch 'sosexprbase_hotfix' into 'main' (diff)
downloadsumofsquares-10b2e89c6d02dd396c951d652af437687e4db331.tar.gz
sumofsquares-10b2e89c6d02dd396c951d652af437687e4db331.zip
Add pyproject.toml with Poetry
Diffstat (limited to '')
-rw-r--r--pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..def9c86
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,19 @@
+[tool.poetry]
+name = "sumofsquares"
+version = "0.0.1"
+description = "Tools for Sum of Square optimization"
+authors = ["Michael Schneeberger <michael.schneeberger@fhnw.ch>"]
+readme = "README.md"
+
+[tool.poetry.dependencies]
+python = ">=3.10"
+polymatrix = {git = "https://gitlab.ethz.ch/npross/polymatrix.git"}
+cvxopt = "^1.3.2"
+
+
+[tool.poetry.group.notebook.dependencies]
+marimo = "^0.2.7"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"