summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorNao Pross <np@0hm.ch>2024-05-26 12:44:22 +0200
committerNao Pross <np@0hm.ch>2024-05-26 12:44:22 +0200
commit6ef765d34417b701d5ebf82aeab1fdff9442942d (patch)
tree655eaa2bd1e6779c5c7a67c1ec2eb551ab3bf047 /pyproject.toml
parentDelete unused imports and minor changes (diff)
downloadsumofsquares-6ef765d34417b701d5ebf82aeab1fdff9442942d.tar.gz
sumofsquares-6ef765d34417b701d5ebf82aeab1fdff9442942d.zip
Add SCS dependency to pyproject.toml, limit Python version to 3.13 for MOSEK
Diffstat (limited to '')
-rw-r--r--pyproject.toml9
1 files changed, 4 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index cf4c9c6..249bb29 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,15 +6,14 @@ authors = ["Michael Schneeberger <michael.schneeberger@fhnw.ch>"]
readme = "README.md"
[tool.poetry.dependencies]
-python = ">=3.10"
polymatrix = {git = "https://gitlab.ethz.ch/npross/polymatrix.git"}
python = ">=3.10,<3.13"
-cvxopt = "^1.3.2"
-mosek = "^10.1.31"
-
+cvxopt = ">=1.3.2"
+mosek = ">=10.1.31"
+scs = ">=3.2.4.post1"
[tool.poetry.group.notebook.dependencies]
-notebook = "^7.1.3"
+notebook = ">=7.1.3"
[build-system]
requires = ["poetry-core"]