summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 4 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index cf4c9c6..249bb29 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,15 +6,14 @@ authors = ["Michael Schneeberger <michael.schneeberger@fhnw.ch>"]
readme = "README.md"
[tool.poetry.dependencies]
-python = ">=3.10"
polymatrix = {git = "https://gitlab.ethz.ch/npross/polymatrix.git"}
python = ">=3.10,<3.13"
-cvxopt = "^1.3.2"
-mosek = "^10.1.31"
-
+cvxopt = ">=1.3.2"
+mosek = ">=10.1.31"
+scs = ">=3.2.4.post1"
[tool.poetry.group.notebook.dependencies]
-notebook = "^7.1.3"
+notebook = ">=7.1.3"
[build-system]
requires = ["poetry-core"]