aboutsummaryrefslogtreecommitdiffstats
path: root/src/pyproject.toml
diff options
context:
space:
mode:
authorNao Pross <np@0hm.ch>2021-10-22 15:12:50 +0200
committerNao Pross <np@0hm.ch>2021-10-22 15:12:50 +0200
commit6e991174232667434cc1eee48a27218cd8527184 (patch)
tree743c3d0765d9579addca6a7ab5c9b46c5ee7d0f0 /src/pyproject.toml
parentMake gr block compilable (diff)
downloadFading-6e991174232667434cc1eee48a27218cd8527184.tar.gz
Fading-6e991174232667434cc1eee48a27218cd8527184.zip
Create pyproject file with poetry to work on other distros
Diffstat (limited to '')
-rw-r--r--src/pyproject.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/pyproject.toml b/src/pyproject.toml
new file mode 100644
index 0000000..a46619a
--- /dev/null
+++ b/src/pyproject.toml
@@ -0,0 +1,16 @@
+[tool.poetry]
+name = "fading_ui"
+version = "0.1.0"
+description = "User Interface for RX device"
+authors = ["Nao Pross <np@0hm.ch>"]
+
+[tool.poetry.dependencies]
+python = ">=3.8,<3.11"
+dearpygui = "^1.0.2"
+numpy = "^1.21.3"
+
+[tool.poetry.dev-dependencies]
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"