aboutsummaryrefslogtreecommitdiffstats
path: root/video/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--video/shell.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/video/shell.nix b/video/shell.nix
new file mode 100644
index 0000000..bdb2575
--- /dev/null
+++ b/video/shell.nix
@@ -0,0 +1,27 @@
+with import <nixpkgs> {};
+let
+ manimpango = callPackage manimpango/default.nix {
+ buildPythonPackage = pkgs.python3Packages.buildPythonPackage;
+ fetchPypi = pkgs.python3Packages.fetchPypi;
+ };
+
+ mapbox-earcut = callPackage manimgl/mapbox-earcut.nix {
+ buildPythonPackage = pkgs.python3Packages.buildPythonPackage;
+ fetchPypi = pkgs.python3Packages.fetchPypi;
+ };
+
+ manimgl = callPackage manimgl/default.nix {
+ buildPythonApplication = pkgs.python3Packages.buildPythonApplication;
+ buildPythonPackage = pkgs.python3Packages.buildPythonPackage;
+ fetchPypi = pkgs.python3Packages.fetchPypi;
+ pythonOlder = pkgs.python3Packages.pythonOlder;
+ manimpango = manimpango;
+ mapbox-earcut = mapbox-earcut;
+ };
+
+in mkShell {
+ buildInputs = [ manimpango manimgl ];
+ shellHook = ''
+ manimgl qam.py
+ '';
+}