aboutsummaryrefslogtreecommitdiffstats
path: root/notebook/shell.nix
diff options
context:
space:
mode:
authorNaoki Pross <np@0hm.ch>2021-10-19 18:26:52 +0200
committerNaoki Pross <np@0hm.ch>2021-10-19 18:26:52 +0200
commit69687406bb97f2e99320374dc50e6b0f4645ff9a (patch)
treecb7cc44849b1b7fdf962bab4b1d99a9139a619d4 /notebook/shell.nix
parentContinue sampling (diff)
downloadDigSig1-69687406bb97f2e99320374dc50e6b0f4645ff9a.tar.gz
DigSig1-69687406bb97f2e99320374dc50e6b0f4645ff9a.zip
Create jupyter notebook
Diffstat (limited to '')
-rw-r--r--notebook/shell.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/notebook/shell.nix b/notebook/shell.nix
new file mode 100644
index 0000000..b7599dd
--- /dev/null
+++ b/notebook/shell.nix
@@ -0,0 +1,25 @@
+with (import <nixpkgs> {}).pkgs;
+let
+
+# jupyterlab-vim = python3.pkgs.buildPythonPackage rec {
+# pname = "jupyterlab_vim";
+# version = "0.14.5";
+# src = python38.pkgs.fetchPypi {
+# inherit pname version;
+# sha256 = "10p294vkha8c485yr2x1j3y084k86crzc7ihcb1wj6cd54plyybl";
+# };
+# buildInputs = with python3Packages; [
+# jupyterlab
+# jupyter-packaging
+# ];
+# };
+
+in
+mkShell {
+ buildInputs = (with python3Packages; [
+ ipykernel jupyterlab sympy
+ matplotlib numpy pint
+ ]) ++ [
+ # jupyterlab-vim
+ ];
+}