aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNao Pross <naopross@thearcway.org>2018-02-25 21:11:02 +0100
committerNao Pross <naopross@thearcway.org>2018-02-25 21:11:02 +0100
commitbe6642dc096842f0531c7687cf06f15fd1d0ccd6 (patch)
treeb7c81d15936e29087f8ec0c0df1c5d334817b0a0 /CMakeLists.txt
parentFix all warnings (errors with -Werror) (diff)
downloadSubconscious-old-be6642dc096842f0531c7687cf06f15fd1d0ccd6.tar.gz
Subconscious-old-be6642dc096842f0531c7687cf06f15fd1d0ccd6.zip
Update CMakeLists and Makefile
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 98b9ba1..16dd487 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,7 +46,18 @@ install(TARGETS ${EXECUTABLE_NAME} DESTINATION bin)
# CPack packaging
include(InstallRequiredSystemLibraries)
+
+set(CMAKE_PACKAGE_NAME "subconcious")
+
+set(CPACK_GENERATOR "DEB;ZIP;TGZ;STGZ")
+
# set(CPACK_RESOURCES_FILE_LICENSE "${CMAKE_SOURCE_DIR}/COPYING")
set(CPACK_PACKAGE_VERSION_MAJOR "${subconscious_VERSION_MAJOR}")
set(CPACK_PACKAGE_VERSION_MINOR "${subconscious_VERSION_MINOR}")
+
+# debian package
+set(CPACK_DEBIAN_PACKAGE_ARCHITECTURE "amd64")
+set(CPACK_DEBIAN_PACKAGE_MAINTAINER "Nao Pross <naopross@thearcway.org>")
+set(CPACK_PACKAGE_DEBIAN_DESCRIPTION "RPG game")
+
include(CPack)