aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNao Pross <naopross@thearcway.org>2018-02-16 21:55:10 +0100
committerNao Pross <naopross@thearcway.org>2018-02-16 21:55:10 +0100
commitbdf602f48194058d998909a233556cc57bac303e (patch)
tree20827387e7c7785329783b1168b0214fc7fc0f52 /CMakeLists.txt
parentMerge branch 'dev' of ssh://git.thearcway.org:2222/naopross/subconscious into... (diff)
downloadSubconscious-old-bdf602f48194058d998909a233556cc57bac303e.tar.gz
Subconscious-old-bdf602f48194058d998909a233556cc57bac303e.zip
Add cpack directive and update README
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b81e25..91774af 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,3 +34,10 @@ endif ()
# install target
install(TARGETS ${EXECUTABLE_NAME} DESTINATION bin)
+
+# CPack packaging
+include(InstallRequiredSystemLibraries)
+# set(CPACK_RESOURCES_FILE_LICENSE "${CMAKE_SOURCE_DIR}/COPYING")
+set(CPACK_PACKAGE_VERSION_MAJOR "${subconscious_VERSION_MAJOR}")
+set(CPACK_PACKAGE_VERSION_MINOR "${subconscious_VERSION_MINOR}")
+include(CPack)