aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b81e25..91774af 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,3 +34,10 @@ endif ()
# install target
install(TARGETS ${EXECUTABLE_NAME} DESTINATION bin)
+
+# CPack packaging
+include(InstallRequiredSystemLibraries)
+# set(CPACK_RESOURCES_FILE_LICENSE "${CMAKE_SOURCE_DIR}/COPYING")
+set(CPACK_PACKAGE_VERSION_MAJOR "${subconscious_VERSION_MAJOR}")
+set(CPACK_PACKAGE_VERSION_MINOR "${subconscious_VERSION_MINOR}")
+include(CPack)