aboutsummaryrefslogtreecommitdiffstats
path: root/src/dearpygui.nix
diff options
context:
space:
mode:
authorNaoki Pross <np@0hm.ch>2021-10-24 15:45:03 +0200
committerNaoki Pross <np@0hm.ch>2021-10-24 15:45:03 +0200
commitf203414b019f95af5b4a9391f1f9962a937e60c0 (patch)
tree048392e6fc3417037c8598397f234af5765fa4c0 /src/dearpygui.nix
parentMake gr block compilable (diff)
downloadFading-f203414b019f95af5b4a9391f1f9962a937e60c0.tar.gz
Fading-f203414b019f95af5b4a9391f1f9962a937e60c0.zip
Create nix overlay for gnuradio
Diffstat (limited to 'src/dearpygui.nix')
-rw-r--r--src/dearpygui.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/src/dearpygui.nix b/src/dearpygui.nix
deleted file mode 100644
index 1b26eaf..0000000
--- a/src/dearpygui.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{ lib, pkgs, buildPythonPackage, fetchPypi, isPy38, autoPatchelfHook }:
-
-assert isPy38;
-
-buildPythonPackage rec {
- pname = "dearpygui";
- version = "1.0.2";
- format = "wheel";
-
- # src = fetchFromGitHub {
- # owner = "hoffstadt";
- # repo = "DearPyGui";
- # rev = "v${version}";
- # sha256 = "094s1r1jjgj6512dp5z5gn50m5g5b7qg6c2wgxhjsn38mxivpd2h";
- # fetchSubmodules = true;
- # };
-
- src = fetchPypi {
- inherit pname version format;
- python = "cp38";
- abi = "cp38";
- platform = "manylinux1_x86_64";
- sha256 = "10y8a3v135pziknnrzg8x5q5l6p7jvxgva8r8l5vjhdq9p5mxnab";
- };
-
- # dontUseCmakeConfigure = false;
- # nativeBuildInputs = with pkgs; [ cmake ];
- nativeBuildInputs = [ autoPatchelfHook ];
-
- buildInputs = (with pkgs; [
- libGL libGL_driver
- ]) ++ (with pkgs.xorg; [
- libX11 libXrandr libXinerama libXcursor libXi
- ]);
-
- meta = with lib; {};
-}