aboutsummaryrefslogtreecommitdiffstats
path: root/src/gr-fading_ui/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorNao Pross <np@0hm.ch>2021-11-03 16:45:52 +0100
committerNao Pross <np@0hm.ch>2021-11-03 16:45:52 +0100
commit8eb48f321a52854ed21fcf6e049adc800cb5c70a (patch)
tree37c3542db96d5331ff013f674184c81921ea1ed3 /src/gr-fading_ui/lib/CMakeLists.txt
parentUpdate workflow (diff)
downloadFading-8eb48f321a52854ed21fcf6e049adc800cb5c70a.tar.gz
Fading-8eb48f321a52854ed21fcf6e049adc800cb5c70a.zip
Remove custom block
Diffstat (limited to 'src/gr-fading_ui/lib/CMakeLists.txt')
-rw-r--r--src/gr-fading_ui/lib/CMakeLists.txt83
1 files changed, 0 insertions, 83 deletions
diff --git a/src/gr-fading_ui/lib/CMakeLists.txt b/src/gr-fading_ui/lib/CMakeLists.txt
deleted file mode 100644
index 29f2336..0000000
--- a/src/gr-fading_ui/lib/CMakeLists.txt
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 2011,2012,2016,2018,2019 Free Software Foundation, Inc.
-#
-# This file was generated by gr_modtool, a tool from the GNU Radio framework
-# This file is a part of gr-fading_ui
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-
-########################################################################
-# Setup library
-########################################################################
-include(GrPlatform) #define LIB_SUFFIX
-
-list(APPEND fading_ui_sources
-)
-
-set(fading_ui_sources "${fading_ui_sources}" PARENT_SCOPE)
-if(NOT fading_ui_sources)
- MESSAGE(STATUS "No C++ sources... skipping lib/")
- return()
-endif(NOT fading_ui_sources)
-
-add_library(gnuradio-fading_ui SHARED ${fading_ui_sources})
-target_link_libraries(gnuradio-fading_ui gnuradio::gnuradio-runtime)
-target_include_directories(gnuradio-fading_ui
- PUBLIC $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/../include>
- PUBLIC $<INSTALL_INTERFACE:include>
- )
-set_target_properties(gnuradio-fading_ui PROPERTIES DEFINE_SYMBOL "gnuradio_fading_ui_EXPORTS")
-
-if(APPLE)
- set_target_properties(gnuradio-fading_ui PROPERTIES
- INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib"
- )
-endif(APPLE)
-
-########################################################################
-# Install built library files
-########################################################################
-include(GrMiscUtils)
-GR_LIBRARY_FOO(gnuradio-fading_ui)
-
-########################################################################
-# Print summary
-########################################################################
-message(STATUS "Using install prefix: ${CMAKE_INSTALL_PREFIX}")
-message(STATUS "Building for version: ${VERSION} / ${LIBVER}")
-
-########################################################################
-# Build and register unit test
-########################################################################
-include(GrTest)
-
-# If your unit tests require special include paths, add them here
-#include_directories()
-# List all files that contain Boost.UTF unit tests here
-list(APPEND test_fading_ui_sources
-)
-# Anything we need to link to for the unit tests go here
-list(APPEND GR_TEST_TARGET_DEPS gnuradio-fading_ui)
-
-if(NOT test_fading_ui_sources)
- MESSAGE(STATUS "No C++ unit tests... skipping")
- return()
-endif(NOT test_fading_ui_sources)
-
-foreach(qa_file ${test_fading_ui_sources})
- GR_ADD_CPP_TEST("fading_ui_${qa_file}"
- ${CMAKE_CURRENT_SOURCE_DIR}/${qa_file}
- )
-endforeach(qa_file)