aboutsummaryrefslogtreecommitdiffstats
path: root/src/shell.nix
diff options
context:
space:
mode:
authorNaoki Pross <np@0hm.ch>2021-10-20 23:40:43 +0200
committerNaoki Pross <np@0hm.ch>2021-10-20 23:40:43 +0200
commit8c37b3b58907bf82110ffe712388df98f7cfdc59 (patch)
treec73864e2deb381604fc05456a5d3e94623fcd1e6 /src/shell.nix
parentPrepare nix env for dearpygui ui (diff)
downloadFading-8c37b3b58907bf82110ffe712388df98f7cfdc59.tar.gz
Fading-8c37b3b58907bf82110ffe712388df98f7cfdc59.zip
Add deps to build out of tree block to nix env
Diffstat (limited to 'src/shell.nix')
-rw-r--r--src/shell.nix21
1 files changed, 7 insertions, 14 deletions
diff --git a/src/shell.nix b/src/shell.nix
index 4503a49..ae4375e 100644
--- a/src/shell.nix
+++ b/src/shell.nix
@@ -8,18 +8,11 @@ let
};
in mkShell {
- buildInputs = [ dearpygui ] ++ (with pkgs; []);
+ buildInputs = [ dearpygui ] ++ (with pkgs; [
+ gnuradio
+ python38Packages.setuptools
+ # gnuradio block dev dependencies
+ cmake pkg-config log4cpp mpir boost175 gmp volk
+ python38Packages.pybind11
+ ]);
}
-
-# (pkgs.buildFHSUserEnv {
-# name = "pipzone";
-# targetPkgs = pkgs: (with pkgs; [
-# python38
-# python38Packages.pip
-# python38Packages.virtualenv
-# libGL
-# libGL_driver
-# xorg.libX11
-# ]);
-# runScript = "bash";
-# }).env