aboutsummaryrefslogtreecommitdiffstats
path: root/src/shell.nix
diff options
context:
space:
mode:
authorNao Pross <np@0hm.ch>2021-11-27 14:46:47 +0100
committerNao Pross <np@0hm.ch>2021-11-27 14:46:47 +0100
commitf263caa2db965ded17cbeb02280dc0174bd73587 (patch)
tree3479b25649ca15132e371a90bc116eb9fc6f2e84 /src/shell.nix
parentTest interpolation angefangen (diff)
downloadFading-f263caa2db965ded17cbeb02280dc0174bd73587.tar.gz
Fading-f263caa2db965ded17cbeb02280dc0174bd73587.zip
Move network code and update nix files
Diffstat (limited to 'src/shell.nix')
-rw-r--r--src/shell.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/shell.nix b/src/shell.nix
index 666bab3..22771e2 100644
--- a/src/shell.nix
+++ b/src/shell.nix
@@ -7,10 +7,18 @@ let
isPy38 = pkgs.python38Packages.isPy38;
};
+ numpy-ringbuffer = callPackage ./nix/numpy-ringbuffer.nix {
+ buildPythonPackage = pkgs.python38Packages.buildPythonPackage;
+ fetchPypi = pkgs.python38Packages.fetchPypi;
+ isPy38 = pkgs.python38Packages.isPy38;
+ };
+
in mkShell {
- buildInputs = [ dearpygui ] ++ (with pkgs; [
+ buildInputs = [ dearpygui numpy-ringbuffer ] ++ (with pkgs; [
gnuradio
python38Packages.setuptools
+ python38Packages.matplotlib
+ python38Packages.numpy
# gnuradio block dev dependencies
cmake ninja pkg-config log4cpp mpir boost175 gmp volk doxygen
python38Packages.pybind11