aboutsummaryrefslogtreecommitdiffstats
path: root/video/manimpango.nix
diff options
context:
space:
mode:
authorNaoki Pross <np@0hm.ch>2021-10-20 19:08:25 +0200
committerNaoki Pross <np@0hm.ch>2021-10-20 19:08:25 +0200
commit2a8e1edcac88d92c50b8b7431fb5eef0c1241582 (patch)
tree477228b73d67230863ab706c6b60afbae22d73d0 /video/manimpango.nix
parentTypos in theory, remove QAM, start QPSK picture (diff)
downloadFading-2a8e1edcac88d92c50b8b7431fb5eef0c1241582.tar.gz
Fading-2a8e1edcac88d92c50b8b7431fb5eef0c1241582.zip
Remove useless folders in video/
Diffstat (limited to 'video/manimpango.nix')
-rw-r--r--video/manimpango.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/video/manimpango.nix b/video/manimpango.nix
new file mode 100644
index 0000000..97b5e97
--- /dev/null
+++ b/video/manimpango.nix
@@ -0,0 +1,22 @@
+{ lib, pkgs, buildPythonPackage, fetchPypi }:
+
+buildPythonPackage rec {
+ pname = "ManimPango";
+ version = "0.3.1";
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "09fc7zv953ni7pilv869ldbjgz59j41a8vbz637rqzjh2yjfb9x3";
+ };
+
+ nativeBuildInputs = with pkgs; [
+ gcc pkgconfig
+ ];
+
+ propagatedBuildInputs = with pkgs; [ pango ]
+ ++ (with pkgs.python3Packages; [
+ cython pytest numpy pillow
+ ]);
+
+ meta = with lib; {};
+}