aboutsummaryrefslogtreecommitdiffstats
path: root/video/nix/manimpango.nix
diff options
context:
space:
mode:
authorNaoki Pross <np@0hm.ch>2021-10-24 23:23:40 +0200
committerNaoki Pross <np@0hm.ch>2021-10-24 23:23:40 +0200
commitaf385473f8ab3c47024612635151bf0f98288f7d (patch)
tree412d14f42ace4a1cc279c08ed8814b900f78d7f2 /video/nix/manimpango.nix
parentCreate QPSK simulation without QT GUI (diff)
downloadFading-af385473f8ab3c47024612635151bf0f98288f7d.tar.gz
Fading-af385473f8ab3c47024612635151bf0f98288f7d.zip
Create TimeDependentComplexPlane tool for video
To draw a QAM signal we will need a way to plot a time dependent complex function. So I made a thing that is just a complex plane + a time axis.
Diffstat (limited to 'video/nix/manimpango.nix')
-rw-r--r--video/nix/manimpango.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/video/nix/manimpango.nix b/video/nix/manimpango.nix
new file mode 100644
index 0000000..97b5e97
--- /dev/null
+++ b/video/nix/manimpango.nix
@@ -0,0 +1,22 @@
+{ lib, pkgs, buildPythonPackage, fetchPypi }:
+
+buildPythonPackage rec {
+ pname = "ManimPango";
+ version = "0.3.1";
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "09fc7zv953ni7pilv869ldbjgz59j41a8vbz637rqzjh2yjfb9x3";
+ };
+
+ nativeBuildInputs = with pkgs; [
+ gcc pkgconfig
+ ];
+
+ propagatedBuildInputs = with pkgs; [ pango ]
+ ++ (with pkgs.python3Packages; [
+ cython pytest numpy pillow
+ ]);
+
+ meta = with lib; {};
+}