aboutsummaryrefslogtreecommitdiffstats
path: root/video/shell.nix
diff options
context:
space:
mode:
authorNaoki Pross <np@0hm.ch>2021-10-24 23:23:40 +0200
committerNaoki Pross <np@0hm.ch>2021-10-24 23:23:40 +0200
commitaf385473f8ab3c47024612635151bf0f98288f7d (patch)
tree412d14f42ace4a1cc279c08ed8814b900f78d7f2 /video/shell.nix
parentCreate QPSK simulation without QT GUI (diff)
downloadFading-af385473f8ab3c47024612635151bf0f98288f7d.tar.gz
Fading-af385473f8ab3c47024612635151bf0f98288f7d.zip
Create TimeDependentComplexPlane tool for video
To draw a QAM signal we will need a way to plot a time dependent complex function. So I made a thing that is just a complex plane + a time axis.
Diffstat (limited to 'video/shell.nix')
-rw-r--r--video/shell.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/video/shell.nix b/video/shell.nix
index 9bd9680..4ee2e41 100644
--- a/video/shell.nix
+++ b/video/shell.nix
@@ -1,16 +1,16 @@
with import <nixpkgs> {};
let
- manimpango = callPackage ./manimpango.nix {
+ manimpango = callPackage ./nix/manimpango.nix {
buildPythonPackage = pkgs.python3Packages.buildPythonPackage;
fetchPypi = pkgs.python3Packages.fetchPypi;
};
- mapbox-earcut = callPackage ./mapbox-earcut.nix {
+ mapbox-earcut = callPackage ./nix/mapbox-earcut.nix {
buildPythonPackage = pkgs.python3Packages.buildPythonPackage;
fetchPypi = pkgs.python3Packages.fetchPypi;
};
- manimgl = callPackage ./manimgl.nix {
+ manimgl = callPackage ./nix/manimgl.nix {
buildPythonApplication = pkgs.python3Packages.buildPythonApplication;
buildPythonPackage = pkgs.python3Packages.buildPythonPackage;
fetchPypi = pkgs.python3Packages.fetchPypi;
@@ -21,7 +21,7 @@ let
in mkShell {
buildInputs = [ manimpango manimgl ];
- shellHook = ''
- manimgl qam.py
- '';
+ # shellHook = ''
+ # manimgl qam.py
+ # '';
}