aboutsummaryrefslogtreecommitdiffstats
path: root/src/gr-fading_ui/python/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gr-fading_ui/python/CMakeLists.txt')
-rw-r--r--src/gr-fading_ui/python/CMakeLists.txt45
1 files changed, 0 insertions, 45 deletions
diff --git a/src/gr-fading_ui/python/CMakeLists.txt b/src/gr-fading_ui/python/CMakeLists.txt
deleted file mode 100644
index 607267e..0000000
--- a/src/gr-fading_ui/python/CMakeLists.txt
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2011 Free Software Foundation, Inc.
-#
-# This file was generated by gr_modtool, a tool from the GNU Radio framework
-# This file is a part of gr-fading_ui
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-
-########################################################################
-# Include python install macros
-########################################################################
-include(GrPython)
-if(NOT PYTHONINTERP_FOUND)
- return()
-endif()
-
-########################################################################
-# Install python sources
-########################################################################
-GR_PYTHON_INSTALL(
- FILES
- __init__.py
- rx_ui_sink.py DESTINATION ${GR_PYTHON_DIR}/fading_ui
-)
-
-########################################################################
-# Handle the unit tests
-########################################################################
-include(GrTest)
-
-set(GR_TEST_TARGET_DEPS gnuradio-fading_ui)
-set(GR_TEST_PYTHON_DIRS ${CMAKE_BINARY_DIR}/swig)
-GR_ADD_TEST(qa_rx_ui_sink ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/qa_rx_ui_sink.py)