aboutsummaryrefslogtreecommitdiffstats
path: root/src/nix/numpy-ringbuffer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'src/nix/numpy-ringbuffer.nix')
-rw-r--r--src/nix/numpy-ringbuffer.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/nix/numpy-ringbuffer.nix b/src/nix/numpy-ringbuffer.nix
new file mode 100644
index 0000000..b97b01a
--- /dev/null
+++ b/src/nix/numpy-ringbuffer.nix
@@ -0,0 +1,12 @@
+{ lib, pkgs, buildPythonPackage, fetchPypi, isPy38, autoPatchelfHook }:
+
+buildPythonPackage rec {
+ pname = "numpy_ringbuffer";
+ version = "0.2.1";
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "1vrw38jb3cy9m0c1xxvkk5sf1hpgv58x649a2nnqi9ljdl5wcydc";
+ };
+
+ buildInputs = (with pkgs.python3Packages; [ numpy ]);
+}