aboutsummaryrefslogtreecommitdiffstats
path: root/src/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/pyproject.toml')
-rw-r--r--src/pyproject.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/pyproject.toml b/src/pyproject.toml
new file mode 100644
index 0000000..a46619a
--- /dev/null
+++ b/src/pyproject.toml
@@ -0,0 +1,16 @@
+[tool.poetry]
+name = "fading_ui"
+version = "0.1.0"
+description = "User Interface for RX device"
+authors = ["Nao Pross <np@0hm.ch>"]
+
+[tool.poetry.dependencies]
+python = ">=3.8,<3.11"
+dearpygui = "^1.0.2"
+numpy = "^1.21.3"
+
+[tool.poetry.dev-dependencies]
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"