aboutsummaryrefslogtreecommitdiffstats
path: root/src/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'src/shell.nix')
-rw-r--r--src/shell.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/shell.nix b/src/shell.nix
new file mode 100644
index 0000000..4503a49
--- /dev/null
+++ b/src/shell.nix
@@ -0,0 +1,25 @@
+# vim: set ts=2 sw=2 et:
+with import <nixpkgs> {};
+let
+ dearpygui = callPackage ./dearpygui.nix {
+ buildPythonPackage = pkgs.python38Packages.buildPythonPackage;
+ fetchPypi = pkgs.python38Packages.fetchPypi;
+ isPy38 = pkgs.python38Packages.isPy38;
+ };
+
+in mkShell {
+ buildInputs = [ dearpygui ] ++ (with pkgs; []);
+}
+
+# (pkgs.buildFHSUserEnv {
+# name = "pipzone";
+# targetPkgs = pkgs: (with pkgs; [
+# python38
+# python38Packages.pip
+# python38Packages.virtualenv
+# libGL
+# libGL_driver
+# xorg.libX11
+# ]);
+# runScript = "bash";
+# }).env