aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSophia Papagiannaki <papagiannaki@stettbacher.ch>2020-05-19 18:30:53 +0200
committerSophia Papagiannaki <papagiannaki@stettbacher.ch>2020-05-19 18:30:53 +0200
commitbf0831b3e877ec53f223b73c1de5f6028f24a885 (patch)
tree08e8e605508197a4036592aacc881e4a752bc2cd /CMakeLists.txt
parentadded firmware upgrade function (diff)
downloado3000-driver-bf0831b3e877ec53f223b73c1de5f6028f24a885.tar.gz
o3000-driver-bf0831b3e877ec53f223b73c1de5f6028f24a885.zip
Version 2.1.0
Implemented firmware update.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f61faa9..e25cc1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,8 +16,8 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake)
# library version definition
set(VERSION_MAJOR "2")
-set(VERSION_MINOR "0")
-set(VERSION_RELEASE "3")
+set(VERSION_MINOR "1")
+set(VERSION_RELEASE "0")
set(VERSION_STR "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_RELEASE}")
# pass macros to preprocessor
@@ -37,6 +37,9 @@ add_library( ${LIB_NAME} SHARED
o3000_private.h
o3000_xfer_handler.c
o3000_xfer_handler.h
+ o3000_upgrade.c
+ md5_helper.c
+ md5.c
)
set_target_properties ( ${LIB_NAME} PROPERTIES