summaryrefslogtreecommitdiffstats
path: root/sw/linux/configure.ac
diff options
context:
space:
mode:
authorNao Pross <naopross@thearcway.org>2017-02-14 11:48:19 +0100
committerNao Pross <naopross@thearcway.org>2017-02-14 11:48:19 +0100
commit0bb03c0a1d96c23689cc420238a37b9fd15b739c (patch)
treef2c137723355541788327ae4da6dfc789e78936c /sw/linux/configure.ac
parenthw: created z80acpu in sch library (diff)
downloadz80uPC-0bb03c0a1d96c23689cc420238a37b9fd15b739c.tar.gz
z80uPC-0bb03c0a1d96c23689cc420238a37b9fd15b739c.zip
sw: copied flash tool source from gameboymod
Diffstat (limited to 'sw/linux/configure.ac')
-rw-r--r--sw/linux/configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/sw/linux/configure.ac b/sw/linux/configure.ac
new file mode 100644
index 0000000..a5c4b3b
--- /dev/null
+++ b/sw/linux/configure.ac
@@ -0,0 +1,23 @@
+AC_CONFIG_SRCDIR([src])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_AUX_DIR([build-aux])
+
+AC_INIT([z80prog], [0.1], [naopross@tharcway.org])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+
+AC_PROG_CC
+
+####
+# Check for required packages / libraries
+#
+LIBGTK_REQUIRED=2.91
+
+PKG_CHECK_MODULES(gtk3, [gtk+-3.0 >= $LIBGTK_REQUIRED])
+
+AC_CONFIG_FILES([
+ makefile
+ src/makefile
+])
+
+AC_OUTPUT