aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16dd487..0cade19 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,9 @@ endif()
project(subconscious)
+########################################################################
+# Source Code
+########################################################################
# Configuration headers
set(subconscious_VERSION_MAJOR 0)
set(subconscious_VERSION_MINOR 1)
@@ -20,6 +23,9 @@ include_directories("${PROJECT_SOURCE_DIR}/src/main/headers")
# sources
file(GLOB_RECURSE SOURCES RELATIVE ${CMAKE_SOURCE_DIR} "src/main/cpp/*.cpp")
+########################################################################
+# Binary
+########################################################################
# executable
set(EXECUTABLE_NAME "subconscious")
add_executable(${EXECUTABLE_NAME} ${SOURCES})
@@ -33,6 +39,9 @@ if (MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /W4")
endif ()
+########################################################################
+# Libraies / Dependencies
+########################################################################
# SFML library
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake_modules" ${CMAKE_MODULE_PATH})
find_package(SFML 2 REQUIRED network audio graphics window system)
@@ -41,14 +50,17 @@ if (SFML_FOUND)
target_link_libraries(${EXECUTABLE_NAME} ${SFML_LIBRARIES} ${SFML_DEPENDENCIES})
endif ()
-# install target
-install(TARGETS ${EXECUTABLE_NAME} DESTINATION bin)
+# libtmx
+add_subdirectory("lib/libtmx/src")
+########################################################################
# CPack packaging
+########################################################################
+# install target
+install(TARGETS ${EXECUTABLE_NAME} DESTINATION bin)
include(InstallRequiredSystemLibraries)
set(CMAKE_PACKAGE_NAME "subconcious")
-
set(CPACK_GENERATOR "DEB;ZIP;TGZ;STGZ")
# set(CPACK_RESOURCES_FILE_LICENSE "${CMAKE_SOURCE_DIR}/COPYING")