aboutsummaryrefslogtreecommitdiffstats
path: root/src/shell.nix
diff options
context:
space:
mode:
authorNaoki Pross <np@0hm.ch>2021-10-22 11:18:03 +0200
committerNaoki Pross <np@0hm.ch>2021-10-22 11:40:10 +0200
commitf550c9a343b1c0eb82cebba5aaa497387f184dc4 (patch)
tree8b4c6b1a9f773c40175d1dd16a5ab1ffa02e738b /src/shell.nix
parentCreate (empty) out of tree gnuradio module fading_ui with block rx_ui_sink (diff)
downloadFading-f550c9a343b1c0eb82cebba5aaa497387f184dc4.tar.gz
Fading-f550c9a343b1c0eb82cebba5aaa497387f184dc4.zip
Make gr block compilable
Diffstat (limited to 'src/shell.nix')
-rw-r--r--src/shell.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/shell.nix b/src/shell.nix
index ae4375e..edb49a5 100644
--- a/src/shell.nix
+++ b/src/shell.nix
@@ -12,7 +12,9 @@ in mkShell {
gnuradio
python38Packages.setuptools
# gnuradio block dev dependencies
- cmake pkg-config log4cpp mpir boost175 gmp volk
+ cmake ninja pkg-config log4cpp mpir boost175 gmp volk
python38Packages.pybind11
+ ]) ++ (with pkgs.python38Packages; [
+ numpy
]);
}