aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpatrick.roth <roth@stettbacher.ch>2019-10-21 09:43:33 +0200
committerpatrick.roth <roth@stettbacher.ch>2019-10-21 09:43:33 +0200
commit19289f800e487564e481b1609b8aaac98d3d6cc2 (patch)
tree8ad92349ac1b850392be3167a57b04cff8e75e06 /CMakeLists.txt
parentinitial commit (diff)
downloado3000-color-pipe-19289f800e487564e481b1609b8aaac98d3d6cc2.tar.gz
o3000-color-pipe-19289f800e487564e481b1609b8aaac98d3d6cc2.zip
building instructions for windows added
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3875638..0590745 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,8 +2,15 @@
# Color Image Processing Pipeline
#
+project(O-3000-Color-Pipe)
cmake_minimum_required(VERSION 2.4)
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+# find libo3000 library
+find_package(LibO3000 REQUIRED)
+
include_directories(.)
file(GLOB colorpipesources *.c *.h)