aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPatrick Roth <roth@stettbacher.ch>2019-10-04 11:51:48 +0200
committerPatrick Roth <roth@stettbacher.ch>2019-10-04 11:51:48 +0200
commita0f501fa5650d0b6062cc8f26b34bce11137643d (patch)
tree8e31c5ac3409d4ce48887d88d4530b88a02c2660 /CMakeLists.txt
downloado3000-color-pipe-a0f501fa5650d0b6062cc8f26b34bce11137643d.tar.gz
o3000-color-pipe-a0f501fa5650d0b6062cc8f26b34bce11137643d.zip
initial commit
import from github
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..3875638
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Color Image Processing Pipeline
+#
+
+cmake_minimum_required(VERSION 2.4)
+
+include_directories(.)
+
+file(GLOB colorpipesources *.c *.h)
+
+add_library(o3000_imgpipe SHARED ${colorpipesources})
+
+set_target_properties (o3000_imgpipe PROPERTIES
+ OUTPUT_NAME "o3000_imgpipe"
+ VERSION 1.0.0
+ SOVERSION 1
+ LIBRARY_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}/lib"
+ )
+
+target_compile_options(o3000_imgpipe PRIVATE -Wall -g -O3 -std=c11 -ggdb -D_XOPEN_SOURCE=500 -fPIC)
+
+install(TARGETS o3000_imgpipe DESTINATION lib)
+install(FILES "color_pipe.h" DESTINATION "include/o3000")