aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..3875638
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Color Image Processing Pipeline
+#
+
+cmake_minimum_required(VERSION 2.4)
+
+include_directories(.)
+
+file(GLOB colorpipesources *.c *.h)
+
+add_library(o3000_imgpipe SHARED ${colorpipesources})
+
+set_target_properties (o3000_imgpipe PROPERTIES
+ OUTPUT_NAME "o3000_imgpipe"
+ VERSION 1.0.0
+ SOVERSION 1
+ LIBRARY_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}/lib"
+ )
+
+target_compile_options(o3000_imgpipe PRIVATE -Wall -g -O3 -std=c11 -ggdb -D_XOPEN_SOURCE=500 -fPIC)
+
+install(TARGETS o3000_imgpipe DESTINATION lib)
+install(FILES "color_pipe.h" DESTINATION "include/o3000")