aboutsummaryrefslogtreecommitdiffstats
path: root/src/shell.nix
diff options
context:
space:
mode:
authorNaoki Pross <np@0hm.ch>2021-10-24 15:45:03 +0200
committerNaoki Pross <np@0hm.ch>2021-10-24 15:45:03 +0200
commitf203414b019f95af5b4a9391f1f9962a937e60c0 (patch)
tree048392e6fc3417037c8598397f234af5765fa4c0 /src/shell.nix
parentMake gr block compilable (diff)
downloadFading-f203414b019f95af5b4a9391f1f9962a937e60c0.tar.gz
Fading-f203414b019f95af5b4a9391f1f9962a937e60c0.zip
Create nix overlay for gnuradio
Diffstat (limited to 'src/shell.nix')
-rw-r--r--src/shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/shell.nix b/src/shell.nix
index edb49a5..b6351e8 100644
--- a/src/shell.nix
+++ b/src/shell.nix
@@ -1,7 +1,7 @@
# vim: set ts=2 sw=2 et:
-with import <nixpkgs> {};
+with import <nixpkgs> { overlays = [ (import ./nix/gnuradio-overlay.nix) ]; };
let
- dearpygui = callPackage ./dearpygui.nix {
+ dearpygui = callPackage ./nix/dearpygui.nix {
buildPythonPackage = pkgs.python38Packages.buildPythonPackage;
fetchPypi = pkgs.python38Packages.fetchPypi;
isPy38 = pkgs.python38Packages.isPy38;